我们拥有最专业的技术团队!24小时服务热线:029-88492707
当前位置:西安东方瀚林实业有限公司 - 新闻 - 常见问题 - 浏览文章

h3c命令大全

2018/1/2 9:11:34点击数(0)已有0人评论 加入收藏

思科、华为、ittoday.com.cn" target="_self">H3C的网络设备命令很多,为了更好的掌握这些设备的操作,我们需要先掌握这些设备的命令。


  

   CISCO   H3C   HUAWEI   描述
   no   undo   undo   取消、关闭当前设置
   show   display   display   显示查看
   exit   quit   quit   退回上级
   hostname   sysname   sysname   设置主机名
   en, config terminal   system-view   system-view   进入全局模式
   delete   delete   delete   删除文件
   reload   reboot   reboot   重启
   write   save   save   保存当前配置
   username   local-user   local-user   创建用户
   shutdown   shutdown   shutdown   禁止、关闭 端口
   show version   display version   display version   显示当前系统版本
   show startup-config   display  saved-configuration   display  saved-configuration   查看已保存过的配置
   show running-config   display  current-configuration   display  current-configuration   显示当前配置
   no debug all   ctrl+d   ctrl+d   取消所有debug命令
   erase startup-config   reset saved-configuration   reset saved-configuration   删除配置
   end   return   return   退到用户视图
   exit   logout   logout   登出
   logging   info-center   info-center   指定信息中心配置信息
   line   user-interface   user-interface   进入线路配置(用户接口)模式
   start-config   saved-configuration   saved-configuration   启动配置
   running-config   current-configuration   current-configuration   当前配置
   host   ip host   ip host   host名字和ip地址对应
   交换部分
   enable password   set authentication  password simple   set authentication  password simple   配置明文密码
   interface type/number   interface type/number   interface type/number   进入接口
   interface vlan 1   interface vlan 1   interface vlan 1   进入vlan配置vlan管理地址
   interface rang   interface ethID to ID   interface ethID to ID   定议多个端口的组
   enabl esecret   super password   super password   设置特权口令
   duplex (half|full|auto)   duplex (half|full|auto)   duplex (half|full|auto)   配置接口状态
   speed (10/100/1000)   speed (10/100/1000)   speed (10/100/1000)   配置端口速率
   switchport mode trunk   port link-type trunk   port link-type trunk   配置trunk
   vlan ID /no vlan ID   vlan batch ID /undo vlan batch ID   vlan batch ID /undo vlan batch ID   添加、删除vlan
   switchport access  vlan   port default vlan ID   port acces vlan ID   将端口接入vlan
   show interface   display interface   display interface   查看接口
   show vlan ID   display vlan ID   display vlan ID   查看vlan
   encapsulation   link-protocol   link-protocol   封装协议
   channel-group 1 mode on   port link-aggregation  group 1   port link-aggregation  group 1   链路聚合
   ip routing   默认开启   默认开启   开启三层交换的路由功能
   no switchport   不支持   不支持   开启接口三层功能
   vtp domain   GVRP   GVRP   对跨以太网交换机的VLAN进行动态注册和删除
   spanning-tree vlan ID  root primary   stp instance id root primary   stp instance id root primary   stp配置根网桥
   spanning-tree vlan ID  priority   stp primary vlaue   stp primary vlaue   配置网桥优先级
   show spanning-tree   dis stp brief   dis stp brief   查看STP配置
   路由部分
   ip route 0.0.0.0  0.0.0.0   ip route-static  0.0.0.0 0.0.0.0   ip route-static  0.0.0.0 0.0.0.0   配置默认路由
   ip route 目标网段+掩码 下一跳   ip route-static 目标网段+掩码 下一跳   ip route-static 目标网段+掩码 下一跳   配置静态路由
   show ip route   display ip  routing-table   display ip  routing-table   查看路由表
   router rip /network 网段   rip /network 网段   rip /network 网段   启用rip、并宣告网段
   router ospf   ospf   ospf   启用ospf
   network ip 反码 area <area-id>   area  <area-id>   area  <area-id>   配置OSPF区域
   no auto-summary   rip split-horizon   rip split-horizon   配置RIP V2水平分割
   show ip protocol   display ip protocol   display ip protocol   查看路由协议
   access-list 1-99  permit/deny IP       rule id permit source  IP   rule id permit source  IP   标准访问控制列表
   access-list 100-199  permit/deny protocol source IP+反码  destination IP+反码 operator operan   rule  {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination  <ip wild>|any}[operate]   rule  {normal|special}{permit|deny}{tcp|udp}source {<ip wild>|any}destination  <ip wild>|any}[operate]   扩展访问控制列表
   standby group-number  ip virtual-ip   vrrp vrid number  virtual-ip   vrrp vrid number  virtual-ip   配置HSRP组
   standby group-number  priority   vrrp vrid number  priority   vrrp vrid number  priority   配置HSRP优先级
   standby group-number  preempt   vrrp vrid number  preempt-mode   vrrp vrid number  preempt-mode   配置HSRP占先权
   standby group-number  track

   配置端口跟踪
   ip nat inside source  static   nat server global  <ip> [port] inside <ip> port [protocol]   nat server global  <ip> [port] inside <ip> port [protocol]   配置静态地址转换

               

cisco常用命令解释


视图模式介绍:


普通视图 router>


特权视图 router#    /在普通模式下输入enable


全局视图 router(config)#   /在特权模式下输入config t


接口视图 router(config-if)#       /在全局模式下输入int 接口名称 例如int s0或int e0


路由协议视图 router(config-route)#     /在全局模式下输入router 动态路由协议名称


1、基本配置:


router>enable       /进入特权模式


router#conf t       /进入全局配置模式


router(config)#hostname xxx       /设置设备名称就好像给我们的计算机起个名字


router(config)#enable password    /设置特权口令


router(config)#no ip domain-lookup       /不允许路由器缺省使用DNS解析命令


router(config)#line console 0     /进入控制口的服务模式


router(config-line)#password xxx  /要设置console的密码


router(config-line)#login  /使能可以登陆


router(config-line)#logging synchronous  /日志同步


router(config-line)#exec-timeout 0 0     /设置时间溢出为0


router(config-line)#line vty 0 4  /进入设置telnet服务模式


router(config-line)#password xxx  /设置telnet的密码


router(config-line)#login  /使能可以登陆


router(config-line)#exit   /保存退出到特权模式


router(config)# Service password-encrypt /对所有在路由器上输入的口令进行暗文加密


2、接口配置: 


router(config)#interface serial0  /进入接口配置模式 serial 0 端口配置(如果是模块化的路由器前面加上槽位编号,例如serial0/0 代表这个路由器的0槽位上的第一个接口)


router(config-if)#ip address xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx  /添加ip 地址和掩码


router(config-if)#enca hdl/ppp     捆绑链路协议 hdlc 或者 ppp 思科缺省串口封装的链路层协议是HDLC所以在show run配置的时候接口上的配置没有,如果要封装为别的链路层协议例如PPP/FR/X25就是看到接口下的enca ppp或者enca fr


router(config)#int loopback       /建立环回口(逻辑接口)模拟不同的本机网段


router(config-if)#ip add xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx  /添加ip 地址和掩码给环回口


router(config-if)#no shutdown     /在物理接口上配置了ip地址后用no shut启用这个物理接口反之可以用shutdown管理性的关闭接口




3、路由配置:


(1)静态路由


router(config)#ip route xxx.xxx.xxx.xxx xxx.xxx.xxx.xxx 下一条或自己的接口


router(config)#ip route 0.0.0.0 0.0.0.0 s 0      添加缺省路由


(2)动态路由


rip协议


router(config)#router rip   /启动rip协议


router(config-router)#network xxx.xxx.xxx.xxx    /宣告自己的网段


router(config-router)#version 2     转换为rip 2版本


router(config-router)#no auto-summary     /关闭自动汇总功能,rip V2才有作用


router(config-router)# passive-int  接口名 /启动本路由器的那个接口为被动接口


router(config-router)# nei xxx.xxx.xxx.xxx /广播转单播报文,指定邻居的接ip


igrp协议


router(config)#router igrp xxx      /启动igrp协议 


router(config-router)#network xxx.xxx.xxx.xxx     /宣告自己的网段


router(config-router)#variance xxx  /调整倍数因子,使用不等价的负载均衡


eigrp协议


router(config)router eigrp xxx      /启动协议


router(config-router)#network xxx.xxx.xxx.xxx     /宣告自己的网段


router(config-router)#variance xxx  /调整倍数因子,使用不等价的负载均衡


router(config-router)#no auto-summary       /关闭自动汇总功能


ospf协议


router(config)router ospf xxx       /启动协议启动一个OSPF协议进程


router(config-router)network xxx.xxx.xxx.xxx area xxx /宣告自己的接口或网段在ospf的区域中可以把不同接口宣告在不同区域中


router(config-router)router-id xxx.xxx.xxx.xxx     /配置路由的id


router(config-router)aera xxx stub   /配置xxx区域为末梢区域 加入这个区域的路由器全部要配置这个条命令


router(config-router)aera xxx stub no-summary      /配置xxx区域为完全末梢区域 只在ABR上配置


router(config-router)aera xxx nssa   /配置xxx区域为非纯末梢区域加入这个区域的路由器全部要配置这个条命令


router(config-router)aera xxx nssa no-summary      /配置xxx区域为完全非纯末梢区域 只在ABR上配置,并发布缺省路由信息进入这个区域内的路由器




4、保存当前修改/运行的配置:


router#write    /将RAM中的当前配置存储到NVRAM中,下次路由器启动就是 


           执行保存的配置


router#Copy running-config startup-config   /命令与write效果一样


5、一般的常用命令


router(config-if)#exit


router(config)#


router(config-router)#exit


router(config)#


router(config-line)#exit


router(config)#


router(config)#exit 


router#




exit命令        /从接口、协议、line等视图模式下退回到全局配置模式,或从全局配置模式退回到特权模式


router(config-if)#end


router(config-router)#end


router(config-line)#end


router#




end命令      /从任何视图直接回到特权模式


router#Logout          /退出当前路由器登陆模式相对与windows的注销


router#reload          /重新启动路由器(热启动)冷启动就是关闭路由器再打开电源开关 


特权模式下:


router#show ip route          /查看当前的路由表


router#clear ip route        /清楚当前的路由表


router#show ip protocol       /查看当前路由器运行的动态路由协议情况


router#show ip int brief      /查看当前的路由器的接口ip地址启用情况


router#show running-config    /查看当前运行配置


router#show startup-config    /查看启动配置


router#debug ip pack          /打开ip报文的调试


router#terminal monitor       /输出到终端上显示调试信息


router#show ip eigrp neighbors       /查看eigrp协议的邻居表


router#show ip eigrp top      /查看eigrp协议的拓朴表


router#show ip eigrp interface       /查看当前路由器运行eigrp协议的接口情况


router#show ip ospf neighbor         /查看当前路由器的ospf协议的邻居表


router#show ip ospf interface        /查看当前路由器运行ospf协议的接口情况


router#clear ip ospf process         /清楚当前路由器ospf协议的进程


router#Show interfaces        /显示设置在路由器和访问服务器上所有接口的统计信息. 显示路由器上配置的所有接口的状态


router#Show interfaces serial        /显示关于一个串口的信息


router#Show ip interface      /列出一个接口的IP信息和状态的小结, 列出接口的状态和全局参数




CISCO命令全集 - 思科命令汇总




Access-enable     允许路由器在动态访问列表中创建临时访问列表入口


Access-group      把访问控制列表(ACL)应用到接口上


Access-list       定义一个标准的IP ACL


Access-template          在连接的路由器上手动替换临时访问列表入口


Appn       向APPN子系统发送命令


Atmsig            执行ATM信令命令


B          手动引导操作系统


Bandwidth         设置接口的带宽


Banner motd       指定日期信息标语


Bfe        设置突发事件手册模式


Boot system       指定路由器启动时加载的系统映像


Calendar          设置硬件日历


Cd         更改路径


Cdp enable        允许接口运行CDP协议


Clear      复位功能


Clear counters           清除接口计数器


Clear interface          重新启动接口上的硬件逻辑


Clockrate         设置串口硬件连接的时钟速率,如网络接口模块和接口处理器能接受的速率


Cmt        开启/关闭FDDI连接管理功能


Config-register          修改配置寄存器设置


Configure         允许进入存在的配置模式,在中心站点上维护并保存配置信息


Configure memory         从NVRAM加载配置信息


Configure terminal       从终端进行手动配置


Connect           打开一个终端连接


Copy       复制配置或映像数据


Copy flash tftp          备份系统映像文件到TFTP服务器


Copy running-config startup-config     将RAM中的当前配置存储到NVRAM


Copy running-config tftp        将RAM中的当前配置存储到网络TFTP服务器上


Copy tftp flash          从TFTP服务器上下载新映像到Flash


Copy tftp running-config 从TFTP服务器上下载配置文件


Debug 使用调试功能


Debug dialer 显示接口在拨什么号及诸如此类的信息


Debug ip rip 显示RIP路由选择更新数据


Debug ipx routing activity 显示关于路由选择协议(RIP)更新数据包的信息


Debug ipx sap 显示关于SAP(业务通告协议)更新数据包信息


Debug isdn q921 显示在路由器D通道ISDN接口上发生的数据链路层(第2层)的访问过程


Debug ppp 显示在实施PPP中发生的业务和交换信息


删除文件


Deny 为一个已命名的IP ACL设置条件


Dialer idle-timeout 规定线路断开前的空闲时间的长度


Dialer map 设置一个串行接口来呼叫一个或多个地点


Dialer wait-for-carrier-time 规定花多长时间等待一个载体


Dialer-group 通过对属于一个特定拨号组的接口进行配置来访问控制


Dialer-list protocol 定义一个数字数据接受器(DDR)拨号表以通过协议或ACL与协议的组合来控制控制拨号


Dir 显示给定设备上的文件


Disable 关闭特许模式


Disconnect 断开已建立的连接


Enable 打开特许模式


Enable password 确定一个密码以防止对路由器非授权的访问


Enable password 设置本地口令控制不同特权级别的访问


Enable secret 为enable password命令定义额外一层安全性


Encapsulation frame-relay 启动帧中继封装


Encapsulation novell-ether 规定在网络段上使用的Novell独一无二的格式


Encapsulation PPP 把PPP设置为由串口或ISDN接口使用的封装方法


Encapsulation sap 规定在网络段上使用的以太网802.2格式Cisco的密码是sap


End 退出配置模式


Erase 删除闪存或配置缓存


Erase startup-config 删除NVRAM中的内容


Exec-timeout 配置EXEC命令解释器在检测到用户输入前所等待的时间


Exit 退出所有配置模式或者关闭一个激活的终端会话和终止一个EXEC


Exit 终止任何配置模式或关闭一个活动的对话和结束EXEC


format 格式化设备


Frame-relay local-dlci 为使用帧中继封装的串行线路启动本地管理接口(LMI)


Help 获得交互式帮助系统


History 查看历史记录


Hostname 使用一个主机名来配置路由器,该主机名以提示符或者缺省文件名的方式使用


Interface 设置接口类型并且输入接口配置模式


Interface 配置接口类型和进入接口配置模式


Interface serial 选择接口并且输入接口配置模式


Ip access-group 控制对一个接口的访问


Ip address 设定接口的网络逻辑地址


Ip address 设置一个接口地址和子网掩码并开始IP处理


Ip default-network 建立一条缺省路由


Ip domain-lookup 允许路由器缺省使用DNS


Ip host 定义静态主机名到IP地址映射


Ip name-server 指定至多6个进行名字-地址解析的服务器地址


Ip route 建立一条静态路由


Ip unnumbered 在为给一个接口分配一个明确的IP地址情况下,在串口上启动互联网协议(IP)的处理过程


Ipx delay 设置点计数


Ipx ipxwan 在串口上启动IPXWAN协议


Ipx maximum-paths 当转发数据包时设置Cisco IOS软件使用的等价路径数量


Ipx network 在一个特定接口上启动互联网数据包交换(IPX)的路由选择并且选择封装的类型(用帧封装)


Ipx router 规定使用的路由选择协议


Ipx routing 启动IPX路由选择


Ipx sap-interval 在较慢的链路上设置较不频繁的SAP(业务广告协议)更新


Ipx type-20-input-checks 限制对IPX20类数据包广播的传播的接受


Isdn spid1 在路由器上规定已经由ISDN业务供应商为B1信道分配的业务简介号(SPID)


Isdn spid2 在路由器上规定已经由ISDN业务供应商为B2信道分配的业务简介号(SPID)


Isdn switch-type 规定了在ISDN接口上的中央办公区的交换机的类型


Keeplive 为使用帧中继封装的串行线路LMI(本地管理接口)机制


Lat 打开LAT连接


Line 确定一个特定的线路和开始线路配置


Line concole 设置控制台端口线路


Line vty 为远程控制台访问规定了一个虚拟终端


Lock 锁住终端控制台


Login 在终端会话登录过程中启动了密码检查


Login 以某用户身份登录,登录时允许口令验证


Mbranch 向下跟踪组播地址路由至终端

1、system-view   进入系统视图模式


2、sysname   为设备命名


3、display current-configuration 当前配置情况


4、 language-mode Chinese|English 中英文切换


5、interface Ethernet 1/0/1 进入以太网端口视图


6、 port link-type Access|Trunk|Hybrid      设置端口访问模式


7、 undo shutdown   打开以太网端口


8、 shutdown   关闭以太网端口


9、 quit     退出当前视图模式


10、 vlan 10    创建VLAN 10并进入VLAN 10的视图模式


11、 port access vlan 10   在端口模式下将当前端口加入到vlan 10中


12、port E1/0/2 to E1/0/5    在VLAN模式下将指定端口加入到当前vlan中


13、port trunk permit vlan all    允许所有的vlan通过


H3C路由器



1、system-view   进入系统视图模式


2、sysname R1   为设备命名为R1


3、display ip routing-table 显示当前路由表


4、 language-mode Chinese|English 中英文切换


5、interface Ethernet 0/0 进入以太网端口视图


6、 ip address 192.168.1.1 255.255.255.0   配置IP地址和子网掩码


7、 undo shutdown   打开以太网端口


8、 shutdown   关闭以太网端口


9、 quit     退出当前视图模式


10、 ip route-static 192.168.2.0 255.255.255.0 192.168.12.2 description To.R2 配置静态路由


11、 ip route-static 0.0.0.0 0.0.0.0 192.168.12.2 description To.R2 配置默认的路由


H3C S3100 Switch


H3C S3600 Switch


H3C MSR 20-20 Router




1、调整超级终端的显示字号;


2、捕获超级终端操作命令行,以备日后查对;


3、 language-mode Chinese|English 中英文切换;


4、复制命令到超级终端命令行, 粘贴到主机;


5、交换机清除配置 :<H3C>reset save ;<H3C>reboot ;


6、路由器、交换机配置时不能掉电,连通测试前一定要


检查网络的连通性,不要犯最低级的错误。


7、192.168.1.1/24    等同   192.168.1.1 255.255.255.0;在配置交换机和路由器时, 192.168.1.1 255.255.255.0 可以写成:


192.168.1.1 24


8、设备命名规则:地名-设备名-系列号例:PingGu-R-S3600




H3C华为交换机端口绑定基本配置2008-01-22 13:40


1,端口 MAC


a)AM命令


使用特殊的AM User-bind命令,来完成MAC地址与端口之间的绑定。例如:


[SwitchA]am user-bind mac-address 00e0-fc22-f8d3 interface Ethernet 0/1


配置说明:由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允许PC1上网,而使用其他未绑定的MAC地址的PC机则无法上网。但


是PC1使用该MAC地址可以在其他端口上网。


b)mac-address命令


使用mac-address static命令,来完成MAC地址与端口之间的绑定。例如:


[SwitchA]mac-address static 00e0-fc22-f8d3 interface Ethernet 0/1 vlan 1


[SwitchA]mac-address max-mac-0


配置说明:由于使用了端口学习功能,故静态绑定mac后,需再设置该端口mac学习数为0,使其他PC接入此端口后其mac地址无法被学习。


2,IP MAC


a)AM命令


使用特殊的AM User-bind命令,来完成IP地址与MAC地址之间的绑定。例如:


[SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3


配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定,即与绑定的IP地址或者MAC地址不同的PC机,在任何端口都无法上网。


支持型号:S3026E/EF/C/G/T、S3026C-PWR、E026/E026T、S3050C、E050、S3526E/C/EF、S5012T/G、S5024G


b)arp命令


使用特殊的arp static命令,来完成IP地址与MAC地址之间的绑定。例如:


[SwitchA]arp static 10.1.1.2 00e0-fc22-f8d3


配置说明:以上配置完成对PC机的IP地址和MAC地址的全局绑定。


3,端口 IP MAC


使用特殊的AM User-bind命令,来完成IP、MAC地址与端口之间的绑定。例如:


[SwitchA]am user-bind ip-address 10.1.1.2 mac-address 00e0-fc22-f8d3 interface Ethernet 0/1


配置说明:可以完成将PC1的IP地址、MAC地址与端口E0/1之间的绑定功能。由于使用了端口参数,则会以端口为参照物,即此时端口E0/1只允


许 PC1上网,而使用其他未绑定的IP地址、MAC地址的PC机则无法上网。但是PC1使用该IP地址和MAC地址可以在其他端口上网。



[S2016-E1-Ethernet0/1]mac-address max-mac-0;


进入到端口,用命令mac max-mac-0(端口mac学习数设为0)


[S2016-E1]mac static 0000-9999-8888 int e0/1 vlan 10;


将0000-9999-8888绑定到e0/1端口上,此时只有绑定mac的pc可以通过此口上网,同时E0/1属于vlan 10


就这样,ok了,不过上面两个命令顺序不能弄反,除非端口下没有接pc



dis vlan 显示vlan


name text 指定当前vlan的名称


undo name 取消


[h3c] vlan 2


[h3c-vlan2]name test vlan


dis users 显示用户


dis startup 显示启动配置文件的信息


dis user-interface 显示用户界面的相关信息


dis web users 显示web用户的相关信息。


header login 配置登陆验证是显示信息


header shell


undo header


lock 锁住当前用户界面


acl 访问控制列表 acl number inbound/outbound


[h3c]user-interface vty 0 4


[h3c-vty0-4] acl 2000 inbound


shutdown:关闭vlan接口


undo shutdown 打开vlan接口


关闭vlan1 接口


[h3c] interface vlan-interface 1


[h3c-vlan-interface] shutdown


vlan vlan-id 定义vlan


undo valn vlan-id


display ip routing-table


display ip routing-table protocol static


display ip routing-table statistics


display ip routing-table verbose 查看路由表的全部详细信息


interface vlan-interface vlan-id 进入valn


management-vlan vlan-id 定义管理vlan号


reset ip routing-table statistics protocol all 清除所有路由协议的路由信息.


display garp statistics interface GigabitEthernet 1/0/1 显示以太网端口上的garp统计信息


display voice vlan status 查看语音vlan状态


[h3c-GigabitEthernet1/0/1] broadcast-suppression 20 允许接受的最大广播流量为该端口传输能力的20%.超出部分丢弃.


[h3c-GigabitEthernet1/0/1] broadcast-suppression pps 1000 每秒允许接受的最大广播数据包为1000传输能力的20%.超出部分丢弃.


display interface GigabitEthernet1/0/1 查看端口信息


display brief interface GigabitEthernet1/0/1 查看端口简要配置信息


display loopback-detection 用来测试环路测试是否开启


display transceiver-information interface GigabitEthernet1/0/50 显示光口相关信息


duplex auto/full/half


[h3c]interface GigabitEthernet1/0/1


[h3c-GigabitEthernet1/0/1]duplux auto 设置端口双工属性为自协商


port link-type access/hybrid/trunk 默认为access


port trunk permit vlan all 将trunk扣加入所有vlan中


reset counters interface GigabitEthernet1/0/1 清楚端口的统计信息


speed auto 10/100/1000


display port-security 查看端口安全配置信息


am user-bind mac-addr 00e0-fc00-5101 ip-addr 10.153.1.2 interface GigabitEthernet1/0/1 端口ip绑定


display arp 显示arp


display am user-bind 显示端口绑定的配置信息


display mac-address 显示交换机学习到的mac地址


display stp 显示生成树状态与统计信息


[h3c-GigabitEthernet1/0/1]stp instance 0 cost 200 设置生成树实例0上路径开销为200


stp cost 设置当前端口在指定生成树实例上路径开销。instance-id 为0-16 0表cist 取值范围1-200000


<h3c> display system-guard ip-record 显示防攻击记录信息.


system-guard enable 启用系统防攻击功能


display icmp statistics icmp流量统计


display ip socket


display ip statistics


display acl all


acl number acl-number match-order auto/config


acl-number (2000-2999 是基本acl 3000-3999是高级acl为管理员预留的编号)


rule deny/permit protocal


访问控制


[h3c] acl number 3000


[h3c-acl-adv-3000]rule permit tcp source 129.9.0.0 0.0.255.255 destination 202.38.160.0 0.0.255.255 destination-port eq 80 (


定义高级acl 3000,允许129.0.0/16网段的主机向202.38.160/24网段主机访问端口80)


rule permit source 211.100.255.0 0.255.255.255


rule deny cos 3 souce 00de-bbef-adse ffff-ffff-fff dest 0011-4301-9912 ffff-ffff-ffff


(禁止mac地址00de-bbef-adse发送到mac地址0011-4301-9912且802.1p优先级为3的报文通过)


display qos-interface GigabitEthernet1/0/1 traffic-limit 查看端口上流量


端口速率限制


line-rate inbound/outbound target-rate


inbound:对端口接收报文进行速率限制


outbound: 对端口发送报文进行速率限制


target-rate 对报文限制速率,单位kbps 千兆口 inbound范围1-1000000 outbound范围20-1000000


undo line-rate取消限速.


[h3c]interface GigabitEthernet1/0/1


[h3c-GigabitEthernet1/0/1]line-rate outbound 128 限制出去速率为128kbps


display arp | include 77


display arp 计算arp表的记录数


display ndp 显示交换机端口的详细配置信息。


display ntdp device-list verbose 收集设备详细信息


display lock


display users


display cpu


display memory


display fan


display device


display power


[Quidway]dis cur                                        ;显示当前配置

[Quidway]display current-configuration                  ;显示当前配置

[Quidway]display interfaces                             ;显示接口信息

[Quidway]display vlan all                               ;显示路由信息

[Quidway]display version                                ;显示版本信息


[Quidway]super password                                       ;修改特权用户密码

[Quidway]sysname                                       ;交换机命名

[Quidway]interface ethernet 0/1                               ;进入接口视图

[Quidway]interface vlan x                               ;进入接口视图

[Quidway-Vlan-interfacex]ip address 10.65.1.1 255.255.0.0     ;配置VLAN的IP地址


[Quidway]ip route-static 0.0.0.0 0.0.0.0 10.65.1.2            ;静态路由=网关

[Quidway]rip                                                  ;三层交换支持

[Quidway]local-user ftp


[Quidway]user-interface vty 0 4                               ;进入虚拟终端

[S3026-ui-vty0-4]authentication-mode password                 ;设置口令模式

[S3026-ui-vty0-4]set authentication-mode password simple 222 ;设置口令

[S3026-ui-vty0-4]user privilege level 3                       ;用户级别


[Quidway]interface ethernet 0/1                               ;进入端口模式

[Quidway]int e0/1                                             ;进入端口模式

[Quidway-Ethernet0/1]duplex {half|full|auto}                  ;配置端口工作状态

[Quidway-Ethernet0/1]speed {10|100|auto}                  ;配置端口工作速率

[Quidway-Ethernet0/1]flow-control                        ;配置端口流控

[Quidway-Ethernet0/1]mdi {across|auto|normal}                 ;配置端口平接扭接

[Quidway-Ethernet0/1]port link-type {trunk|access|hybrid}     ;设置端口工作模式

[Quidway-Ethernet0/1]port access vlan 3                  ;当前端口加入到VLAN

[Quidway-Ethernet0/2]port trunk permit vlan {ID|All}        ;设trunk允许的VLAN

[Quidway-Ethernet0/3]port trunk pvid vlan 3          ;设置trunk端口的PVID

[Quidway-Ethernet0/1]undo shutdown                       ;激活端口

[Quidway-Ethernet0/1]shutdown                               ;关闭端口

[Quidway-Ethernet0/1]quit                               ;返回


[Quidway]vlan 3                                         ;创建VLAN

[Quidway-vlan3]port ethernet 0/1                 ;在VLAN中增加端口

[Quidway-vlan3]port e0/1                                 ;简写方式

[Quidway-vlan3]port ethernet 0/1 to ethernet 0/4         ;在VLAN中增加端口

[Quidway-vlan3]port e0/1 to e0/4                         ;简写方式


[Quidway]monitor-port <interface_type interface_num>         ;指定镜像端口

[Quidway]port mirror <interface_type interface_num>         ;指定被镜像端口

[Quidway]port mirror int_list observing-port int_type int_num ;指定镜像和被镜像


[Quidway]description string                              ;指定VLAN描述字符

[Quidway]description                                   ;删除VLAN描述字符

[Quidway]display vlan [vlan_id]                               ;查看VLAN设置


[Quidway]stp {enable|disable}                                 ;设置生成树,默认关闭

[Quidway]stp priority 4096                               ;设置交换机的优先级

[Quidway]stp root {primary|secondary}                    ;设置为根或根的备份

[Quidway-Ethernet0/1]stp cost 200                        ;设置交换机端口的花费


[Quidway]link-aggregation e0/1 to e0/4 ingress|both           ; 端口的聚合

[Quidway]undo link-aggregation e0/1|all                       ; 始端口为通道号


[SwitchA-vlanx]isolate-user-vlan enable                  ;设置主vlan

[SwitchA]isolate-user-vlan <x> secondary <list>          ;设置主vlan包括的子vlan

[Quidway-Ethernet0/2]port hybrid pvid vlan <id>          ;设置vlan的pvid

[Quidway-Ethernet0/2]port hybrid pvid                    ;删除vlan的pvid

[Quidway-Ethernet0/2]port hybrid vlan vlan_id_list untagged ;设置无标识的vlan

如果包的vlan id与PVId一致,则去掉vlan信息. 默认PVID=1。

所以设置PVID为所属vlan id, 设置可以互通的vlan为untagged.

文章由东方瀚林发布,www.ittoday.com.cn


关键字:H3C h3cse h3cne 华三
网友评论
 
热门招聘
网友热评